Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

b1acktoxin

Member
  • Content Count

    8
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About b1acktoxin

  • Title
    Newbie
  1. Update: I did an Aida64 Stability test and ran Heaven for about 20 minutes each, no anomalies, voltages are stable and temps are nothing crazy. Can't seem to find any visual damage o the motherboard and other parts either. Additionally, I've confirmed the PSU fan spins up on boot. I can't seem to figure out what that bang was. but judging from the test results, i'm assuming my system is safe to use? Are there any other test I should run just to be sure?
  2. so the corsair website claims that the fan for the rm650x wont spin up unless it needs to, which might explain why its not spinning on boot and idling.
  3. Good Call! PSU fan is not spinning, all other fans work.
  4. similar sound, definitely not as loud as an actual gun though.
  5. its probably not a good idea to keep using the PC right? Do we know if its specifically the PSU or is there still potentially other sus parts?
  6. The puff was located right under the graphics card between the fans and the PSU shroud, I didn't see the direction it came from but it was a small puff. I don't think it was a cable either as I keep all the cables tucked away from the fans.
  7. I already inspected it, everything looks fine, I didn't open up the PSU or graphics card as i simply don't have the expertise for that. I did peek through the cracks, holes and grills and didn't see anything popped or damaged.
  8. I was playing games on my PC while watching Youtube on a side monitor when something in my case went bang somewhat akin to a gunshot. There was small puff of dust and my computer shut off. Weirdly enough it booted right back up perfectly fine. I've stripped it down and don't see any bad capacitors on the motherboard or inside the PSU (through the grill) and don't smell any burning either. I booted it up and everything seems OK, no weird noises, smells, all components show up in dxdiag. For now, I've shut off the rig and unplugged everything, just in case. Any ideas what happened? What broke? Do I need new parts? Any suggestions on future steps or fixes? EDIT: PSU fan is not spinning, all else is fine. EDIT2: PSU fan is not supposed to spin until under load according to corsairs website. EDIT3: I did an Aida64 Stability test and ran Heaven for about 20 minutes each, no anomalies, voltages are stable and temps are nothing crazy. Can't seem to find any visual damage o the motherboard and other parts either. Additionally, I've confirmed the PSU fan spins up on boot. I can't seem to figure out what that bang was. but judging from the test results, i'm assuming my system is safe to use? Are there any other test I should run just to be sure? Specs: Corsair RM650x 80+ Gold Ryzen 5 2600 MSI RTX 2060 Ventus 6G OC 16(2x8)gb Corsair vengeance RGB PRO MSI B450 Tomahawk motherboard
×