Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Siker

Member
  • Content Count

    26
  • Joined

  • Last visited

Posts posted by Siker


  1. 12 hours ago, xHyPnOtiZeDx said:

    Since I didnt send my laptop yet I tried the Bios upgrade. No FPS drops on Ultra Settings in PUBG training mode which is harder or perfromance I belive due to amount of people randomly shooting at you. So far im cauciously optimistic. Got 75-90 FPS stable. When I tried out of Turbo it did drop but I guess it would. I´ll have a gaming session later and will update the progress. Also I didnt use Ryzen Controller so massive improvement. Gonna try splitgate too, I was getting FPS drops on it before too so hope this solves it! 

     

    EDIT: Time spit - before the Bios update i had framerate drops to 4-7fps every 15 -20 seconds on Low settings. After the update smooth 150 fps with no drops on Epic settings. 

     

    Quake Champions - Unplayable before the updates. Runs smooth 65 -75 on Epic custom settings, no frame drops. 

     

    Seems you did it guys. I´ll keep on testing. 

    That's quite impressive. Never got any kind of these amount of fps. I've had a concern about this laptop and would appreciate some feedback, does anyone have this issue where no matter what graphics settings you run in games you will get the same fps without any visible fps improvementa at all?

     

    For example, if I run Destiny 2 or Dishonored 2 at Ultra, I get the exact same fps as in the lowest settings, wich makes no sense. On FF XV Windows edition, I only get a 20fps difference between Low(70-78fps) and Ultra(45-58)

     

    And  Fortnite is the worse case. If I go from 1080p to 720p in low settings on everything i cant event get more than stable 150fps in 1080p. And 177fps in 720p. And this numbers are when im in creative sitting alone. If I play Arena or public i cant even get more than 100 fps wich is annoying.

     

    It seems that I cant get more than 200 fps, even If i go with the 3D scale to the minimum.

     

    Anyone else experiencing this issue? Is it my hardware that is defective or am I missing something. I have installed the drivers that are in Asus website, I tried to update them to the most recent ones but i get even worse fps.

     

    Idk what to do anymore. I tried the new Bios and still nothing.


  2. 8 hours ago, Bobbydigital said:

    I have a new bios  acquired from someone that got it through their Windows 10 update last month. Luck enough the file was still stored in his Windows directory and he shared it with us. It has yet to appear on the ASUS website or anywhere else that I could find. Haven't tested it much yet but no drops running in Turbo mode and even with the GPU slightly overclocked in MSI Afterburner. 

     

    BIOS 300 Download    https://mega.nz/#!3QEl2ahQ!qFudfEssvaBEeJcQNRv7Kb6YpShqRVfEKsJ2fbuIUBU

     

    BIOS Change Log 

    unknown.png

     

    Would not download by any chance that BIOS. Highly recommend to wait official link from Asus.


  3. 12 hours ago, mussifer said:

    Seems that you have found a real solution to the throttle problem. I can't seem to find the Armoury Crate v.2.5.8, just the v2.5.7, do you have the installer or a link so i can test it out? Thanks

     

    EDIT: Found, just can't find the ThrottlingHelperXML file...

    I'm pretty sure its there, you just don't see it, send me a screenshot of the folder.

     

    Anyways, u just have to run the install.bat w/ Admin.

     

    Try this tweaks as well, use this command lines on the CMD (run it as administrator as well) and type this:

     

    bcdedit /set disabledinamicticks yes

     

    bcdedit /set useplatformclock no

     

    Delete any previous Nvidia driver you have installed, even the one in Asus website is shit. Go yo Nvidia, search for the 441.41 drivers version of the 1660Ti laptop, download, then fresh install. It's one of the most stable versions for this graphic card.

     

    For AMD driver, the best one is the oldest one on the Asus website. Download AMD cleanup utility yo remove any previous driver you had installed and then install the one i told you from Asus.


  4. On 1/26/2020 at 6:14 PM, lamername said:

    I've been reading and doing some testing, and seems like main issue with this laptop is: BIOS sets profile to silent on every reboot, which is broken and is not able to keep the laptop cool, so it gets throttled. On Windows fix is installing armoury crate and setting balanced or turbo profile, and on linux, control of profiles will come with kernel 5.6 (plus setting balanced by default on bootup).

    Is this theory correct? Has anybody had problems when setting the profile out of silent mode on Windows? I installed Windows for the first time on this laptop and was having the exact same issues (maybe even worse) as Linux. I set the fans to balanced and no issues after that (both 207 & 208 BIOS version). Even played around 30 min of Dishonored 2 with relatively high settings, no sweat.

    Not correct. It is not set by default to Silent mode when Armoury Crate not yet installed. When you get a fresh install, the laptop set itself to different modes in order on what are you running, so if you're running a game it presets itself to Turbo mode automatically.

     

    When Armoury Crate installed the laptop behaves the same way, the only thing that this app gives you is to add a manual set to configure both CPU and GPU fans RPM, or force the laptop to wotk on Silent mode even if you're running a game. Nothing else. What actually """"""fixes""""" the throttling is a file called ThrottlingHelperXML, that is included in the same zip file from where you install ArmouryCrate v2.5.8

     

    My unit doesn't throttle anymore, even if I play 8 hours in a row any gme at any graphic setting. Not sure what I've done exactly. The only issue I'm still getting in my case is shitty performance. For example, in Dishonored 2 I get only 82fps max on low preset with drops to 60-40fps wich is bullshit and makes it unplayable. And if I go all way up and crank the setting to Ultra I get the same performance as in low preset w 74fps max and same fps drops.


  5. On 1/14/2020 at 9:32 PM, lamername said:

    I'm wondering if doing the vent fix voids the warranty. It would be sad to do a fix for a broken product while still on warranty and lose it.

    Removing just the plastic doesn't avoid it, atleast it doesnt if your retailer is Amazon. If you furthermore remove the covers linked to the fans, you lose it. Ask the shop where you bought it about the plastic and decide if to do it or not. I actually do not recommend buying this shitty ass laptop or keeping it if you can actually claim a refund. Even when I do not have any issues anymore with thermal or cpu throttling (idk what I did to fix ot honestly, because i didnt remove the covers linked to the fans) without using MSI afterburner or Ryzen Controller but it still annoys me that Asus gives shit about everyone who bought this model and on top of it, it wont give any good fps in most games so I can't even enjoy the 120fps monitor. Hot useless garbage. Ffs, even Acer predator 300 w shittiest graphic card and cpu rocks up games more than mine, so fing sad.


  6. 19 hours ago, Churrucaman said:

    I wouldn't say we have enough samples to jump to a conclusion but having more details on his config, bios version, etc may give us a lead. Anybody else that may be aware of other users not getting the problem could also be of use, just to know if we may help us understand if this is happening in all cases or if it may depend on the batch or whatever.

     

    As users that have made several RMAs are still facing the same problem I was thinking it would be a general issue but who knows...

     

    Still, CS:GO and Dota2, though at least in the first case causes throttling when maxed, there's some fps oriented configurations that may not stress the system enough. What I mean is that we would need more testing from this users that say they're not getting the problem before we can place this as a model defect or just limited to some batches.

    On a spanish forum, a guy w latest BIOS, drivers and Windows 10 didnt experience any issues during long gaming sessions. He didnt have to remove any fan cover or do any thermal pasting so idk anymore what to say on this issue w this laptops :////


  7. 15 hours ago, Bobbydigital said:

    Yeah with just those set  and temp at 90 it works great over here. I've been poking around in the BIOS rom file and have extracted the DSDT tables which hold all the settings that you can change in Ryzen Controller and I've found most of the stuff I need to edit. I should then be able to inject the module back into the BIOS file,flash the file and we won't have to use Ryzen Controller anymore!

    Idk dont fix anything for me, I still get 46 to 21 fps drops and cant use all my CPU power at all even w that build in ryzen controller. Stuck at 3.21 GHZ sow erid


  8. On 12/20/2019 at 3:55 PM, Rkes608 said:

    Hi all no update from Asus but I have been using this laptop solidly and no issues after fan plastic cover was removed. 

    I emailed chasing them. @rrff

     

    @zxcvbnm123 tbh it shouldn't void the warrenty I don't think. Like removing or chipping of a piece of the case by accident. It's up to you once plastic is removed this laptop is a beast. 

     

    If you brought from a tech place like currys PC World in UK or best buy in US for example try taking it to their tech department and show them the plastic. Maybe they'll remove for you 

     

     

    Can you show an image or how you actually removed them? Idk exactly what I need to remove.


  9. So Ive been using the laptop a lot this days to play Fortnite and Destiny 2. Seems I habe no more 0.39GHz throttling but still have fps drops from 120 to 40-60, and when im going Ultra graphics even to 20 fps. Thing is I never surpass the 190 fos in fortnite with everything in low, even the 3D resolution set to 40% lmao

     

    Anyone who fixed the throttling issue with repasting it or removing the fans can actually get 240fps in games like fortnite or cs go?

     

    Its like when i go with low setting on Destiny 2 it runs at max perfomance 100fps and drops to 90 fps and when Ii switch to Ultra graphs it still going with 90 fps and makes no sense for me.... any idea or suggestion?


  10. 1 hour ago, dd12rock said:

    I also spoke with Asus proactive care and they asked me to send in a form with a bunch of information so their engineers can replicate the issue. I called back a few days later to ask about the status of it and they said they don't do that and the only way they can help is if I send my computer in. I'm pretty sure they're just trying to make it seem like they care, but they're not actually doing anything about it.

    People were complaining on twitter and they shitted on then basically. So yeah, it seems that paying 1k bucks on their hardware doesn't deserve their attention at all. What a joke, at this rythm we ain't getting a Bios update until everyone is done with this model and send it back to bargain where it belongs.


  11. 1 hour ago, mijo said:

    Hello everyone. I'm having the same issue with CPU speeds droping down to 400. But I think, it is not a CPU issue, it's got to do with the Nvidia GPU. I was playing around with Unigine Heaven and monitoring the temps and speed. Every time the GPU hits around 72 degree, the CPU drops to 400 Mhz. After playing with temp limit in Ryzen Controller, i've got CPU temperatures as low as 70 degrees in Heaven, but still drops to 400 Mhz, when the GPU temps were above 70 degrees. It seems like the GPU is making this drops. I don't know if it is a BIOS or Windows 10 problem.

    BIOS problem. You can see on youtube that there is old reviews that have not had this issue. But then I see people that bought it wery recebtly and havent experienced any issue, so idk anymore. .aybe its mixed hardware and bios defect.


  12. 7 hours ago, simpleas said:

    I have reinstalled all the graphics drivers etc. When i disable the integrated graphics card I can't load games at all which is strange too? I'm out of ideas

    That's actually weird. Does the GTX appears on your pc settings when you go to This PC properties? I've never heard about something like this. Nevertheless, wether the graphic appears or not on Armoury Crate doesn't matter at all, do you get good framerates in games? The integrated graphics only have 128MB so by itself it can't do anything, im pretty sure you have enabled the GTX, if you have the drivers, theb go to desktop, right control, NVIDIA control panel and then select it manually.

     

    And last thing, create a new power energy plan, a High Perfomance one.

     

    If nothing of this actually works, im run out of ideas.

     

    Order another replacement or just send it back. As i said, AMD is fing up really hard with this mobile CPUs and some companies like Asus are not dealing with this issue as they not fixing it by a BIOS update. And up to that, in your case seems that the GPU is failing too. I'm just starting to think that this line of product is absolute crap.


  13. 10 minutes ago, simpleas said:

    Same issues with the replacement. 1660ti still does not show and same drops in-game. 

     

    Massively dissapointed. Two new units and still same issues- maybe i'm missing something? I have settings enabled to turbo?

    Have you tried to uninstal literally every driver you have and installing only the ones on Asus website? Do it, it may fix it. But however, i think you gonna still having throttling issues. It sucks, if this happens to me im gonna send it back, im starting to give up w AMD.


  14. 2 hours ago, simpleas said:

    Bought the GA502 from John lewis with the same issue. Replacing it for a brand new one tonight and I'm hoping I get a unit from a different batch without these issues. 

     

    On my armoury crate the 1660ti didn't even show up? It only mentioned the integrated graphics card. Is this the same for everyone else? 

    Yess, i finally got Amazon to send me a replacement. It gonna arrive this sunday, hope it runs well without any issues.

     

    So what about you did everything went fine??


  15. 1 hour ago, simpleas said:

    Bought the GA502 from John lewis with the same issue. Replacing it for a brand new one tonight and I'm hoping I get a unit from a different batch without these issues. 

     

    On my armoury crate the 1660ti didn't even show up? It only mentioned the integrated graphics card. Is this the same for everyone else? 

    Nope, the normal thing is to get the GTX displayed on the Armoury Crate. That's good new for you!! Hope it run well without any issues. I tried to get a replace from Amazon but they saying that they have no references (lol what an excuse) so they cant replace it for me.


  16. On 11/28/2019 at 2:04 PM, Rkes608 said:

    Btw, I actually have a concern about my Integrated GOU Vega RX 10, when I'm runnkng games it goes al way up to 50~80% of usage, is this normal? I thought all the work was on the GTX 1660Ti but seems that when im playing games the Vega RX 10 is doing some work too. I'm pretty upset would be amazing to know if you guys have this same thing as I'm not sure if its an issue or not.

×