Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Sonnydeelite

Member
  • Content Count

    16
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Sonnydeelite

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have windows 10 on the USB but my PC isnt loading the installer when I boot the system.
  2. I'm trying to download windows on a clean drive from a USB. Temps are fine as well.
  3. 16gb ddr4 ram corhair , gtx 1070, 120 GB ssd adata, corshair 750x psu
  4. I just upgraded my motherboard to a msi mpg z390 pro carbon ac and my CPU to Intel i7 9700k. Also upgraded my CPU cooler as well. When I installed all parts into the case , my PC won't boot. Sometimes I can get to a point where I try to install windows but it freezes all the time. I can get into bios and stuff but whenever I try to load windows it freezes. Any ideas ?
  5. Ok guys I finally got my PC to turn on but now everytime I try to boot it up it freezes. Sometimes it let's me get into downloading windows but inevitably it freezes again. I can enter bios though. Any ideas ?
  6. The cables from the psu were working, I checked them with a volt meter. And I'm pretty sure the power switch cable is correct but the instructions were a bit confusing for me.
  7. Yea already checked if outlet works , also no lights no fans , nothing at all.
  8. So do you know what could be wrong then if both are connected
  9. So do you know what could be wrong then if both of them are plugged in
  10. I already ordered a new PSU that has 12 pin. So is their anything else that could be wrong with it besides that or are you 100 percent sure you need all 12 pins ?
  11. Yea everything else is as you said. I already ordered a new PSU that has 12 pin capability so maybe that's what it is, but could it be anything else ?
  12. I only have 8 pins plugged into the CPU power but I didnt think it was essential to have all 12 in. Is it ?
  13. I also ordered a new psu because I thought that my CPU needed a 12 pin connector to work but I read on a different topic that is not required.
  14. I just upgraded my motherboard to a msi mpg z390 pro carbon ac and my CPU to Intel i7 9700k. Also upgraded my CPU cooler as well. When I installed all parts into the case , my PC won't boot at all. There is no lights and no fans that run. I'm sure that the case switches are set up correctly and I know I didnt fry the board because there was no smell. Any ideas ?
×