Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

AmrAdel

Member
  • Content Count

    2
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About AmrAdel

  • Title
    Newbie
  1. I took out the GPU and tried the MB graphics, and still the same problem, black screen and no light on the RAM modules. Do you have any other suggestins?
  2. I built a new PC with the following configuration: Processor: Intel i7 8700 Case: NZXT H200 M.B.: Gigabyte z370N - Wifi RAM: Corsair Vengeance RGB 16GB (2x8GB) DDR4 3000MHz C15 Desktop Memory GPU: Gigabyte AORUS GeForce RTX 2060 Xtreme 6G Graphics Card, SSD; 1-WD Blue 3D NAND 1TB PC SSD - SATA III 6 Gb/s, M.2 2280 2- Samsung 970 EVO 500GB - NVMe PCIe M.2 2280 SSD PSU: CORSAIR TXM Series, TX750M, 750 Watt, 80+ Gold Certified, Semi Modular Power Supply The PC was working perfectly for 2 weeks, then suddenly when I switch it on the screen is black although there is power. I noticed the following: - The MB have power connected as the LED is on - The GPU is on as the fan is on and the RGB light is on - The fans are all operational - The RAM RGB light is OFF. I assumed it is the RAM fauilure, I tried to replace take them out clean them and put them on again but the situation is till the same, I assume the RAM is the problem so I will buy a new one, but I need your help: - is there a way to confirm it is the RAM causing the problem? - Is there any other suggestions to troubleshoot the problem? Thank You
×