Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

QuinTx

Member
  • Content Count

    4
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About QuinTx

  • Title
    Newbie

System

  • CPU
    i5 4750
  • Motherboard
    gigabyte ga-h81m-h
  • RAM
    8gb dual ddr3 HyperX 1.6GHz
  • GPU
    ROG rx 460
  • PSU
    corsair cx 600m
  • Display(s)
    Acer g246hlabd
  • Cooling
    Cooler Master Hyper 212 Evo
  • Keyboard
    Razer black widow 2016 edition
  • Mouse
    Logitech G403
  • Operating System
    Windows 10 64bit
  1. yes. and i have updated all my drivers
  2. i tried that, the issue is still here
  3. This problem started a few days ago and i have never had a problem beforehand. Whenever i hop into World of Warcraft my computer starts playing the usb disconnect/reconnect notification noise sporadically during a loading screen plays on and off until i quit the program. Every once in a while it gives me a notification that i had a usb malfunction and to reconnect the said usb, but i haven't added anything new to my peripherals or devices, then it stops and doesn't do it in any other program. I have updated all my drivers and have updated windows trying to resolve the issue. I have even unplugged everything from my usb ports and the problem still persists. Any help would be appreciated, as it has made playing one of my favorite games unplayable.
  4. My brother is in his junior year of college and the program he's enrolled in involves using a lot of programs like Solidworks, and his laptop with his i5 4210u and his 6gb of ram and intel integrated graphics is having trouble keeping up...he never plays any games on his laptop, so what would be the best option for him to upgrade for better performance?
×