Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

NDBroughton

Member
  • Content Count

    43
  • Joined

  • Last visited

Awards


About NDBroughton

  • Title
    Member
  • Birthday April 16

Contact Methods

  • Discord
    Nate [ACA30]#0001
  • Steam
    ACA30
  • Battle.net
    ACA30#1185
  • Reddit
    b4technology
  • Twitch.tv
    aca30doesgames
  • Twitter
    aca30doesgames
  • Website URL

Profile Information

  • Gender
    Male
  • Location
    Ontario

System

  • CPU
    i7-8700k
  • Motherboard
    MSI Z370-A Pro
  • RAM
    16GB DDR4
  • GPU
    GTX 1070 Ti
  • Storage
    240GB Sata SSD | 1TB HDD
  • Display(s)
    2x 1080p 60Hz
  • Keyboard
    Razer Cyanosa Chroma
  • Mouse
    Razer DeathAdder Elite
  • Operating System
    Windows 10 Pro

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Here's my "gigabit" internet connection that I pay over $100 CAD a month for... thanks Cogeco and damn, look at these 100% legit system requirements for the gigabit internet
  2. From what I can see there's not really other sources for this story. The links work most of the time...
  3. From my understanding, that error is mostly caused by display/graphics issues. Try updating your graphics card drivers?
  4. Although I can't find a specific release date, I believe it was going to be released some time this spring? So hopefully soon as opposed to mid-June...
  5. It's probably not an issue with the PSU age. Although it does degrade over time, it wouldn't be that much, and 750W is plenty for the setup you have. Is it possible it's an issue caused by thermals? Did you remember thermal paste?
  6. That seems odd to me as well, I'm not 100% sure to be honest with you. I did Google around for a button but I couldn't find what it would be. However, a user on another forum said you could try this, if it doesn't work, it's possible there is no button. Again, I don't have the keyboard, so I'm just Googling around and am not 100% sure, but this is just the way it's looking.
  7. Update: A follow-up article providing an in-depth look at "New IP" was just posted. Pretty long, but interesting. Take a read.
  8. This is something you might want to take a look at. Good luck!
  9. Amazon is your friend too, if it's available in your area... Something like this EVGA one would be good for you. You can also just search Amazon for "450W power supply" and find a decently priced one from a good brand. When you buy a new one, make sure its from a reputable brand and not a random Chinese one again (Corsair, EVGA, SilverStone, Cooler Master, Be Quiet!, etc)
  10. my point is that my guess on currency for my suggestion was correct, so this is within your budget...
  11. From my limited phone knowledge, the Motorola Moto G7 Play is probably about the best you'll get in that price range. Phones are unfortunately very expensive nowadays... https://www.gsmarena.com/alcatel_3v-9004.php (assuming $150-200 USD)
  12. You don't need to, just open afterburner, switch to the game, play for a bit, switch back to afterbutner, and look at the temperature graphs & stuff after.
  13. AFAIK DDU is an uninstaller. You need to re-install the updated drivers (https://www.geforce.com/drivers/results/159091). From your post wording, I'm not sure if you did this or not.
×