Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...

valdyrgramr

Member
  • Content Count

    11,927
  • Joined

  • Last visited

Awards


About valdyrgramr

  • Title
    Lone Wolf Odinist
  • Birthday 1990-08-23

Profile Information

  • Gender
    Male
  • Location
    Sander, Norway[Fam from] I'm in 'Murika
  • Interests
    Programming, music, guitar, anime, x-files, video games, game devng, Norse, ancient civ, my ancestors of Norway, and technology.
  • Biography
    Odinist, musician, gamer, techie, otaku, and an ancient civ and ITS/C++ major with game dev electives.
  • Occupation
    Student

System

  • CPU
    AMD - Threadripper 1950X 3.4GHz 16-Core Processor
  • Motherboard
    ASRock - X399 Taichi ATX TR4 Motherboard
  • RAM
    G.Skill Ripjaws V Series 32GB (2x16GB) DDR4-3200MHz
  • GPU
    Zotac Amp GTX 1080
  • Case
    Fractal Design - Define R5 Blackout Edition w/ Window ATX Mid Tower Case
  • Storage
    Crucial MX500 500GB SATA 2.5 Inch Internal Solid State Drive, ES.3 Constellation 7200rpm 128mb cache, and a 4TB X300.
  • PSU
    EVGA G2 750w
  • Display(s)
    AOC U2879VF 28'' 4K UHD 2160p 60hz with Freesync+Acer GN246HL 144hz 1080p plus using a 4k tv as a 3rd from TCL
  • Cooling
    EKWB S280 Kit with the nickel sTR4 EKWB block added to it, kryronaut, and blood red premix
  • Keyboard
    Corsair K70 With Cherry MX Red Switches.
  • Mouse
    Corsair M65 Pro RGB
  • Sound
    Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone, Massdrop AKG K7XX Audiophile Headphones, Hyper X Cloud II+Mackie MR624 Studio Monitors
  • Operating System
    Microsoft Windows 10 Pro - 64-bit (OEM) (64-bit)
  • PCPartPicker URL

Recent Profile Visitors

20,580 profile views

Single Status Update

See all updates by valdyrgramr

  1. Well, gotta RMA the Taichi X399 board.  Ram works in my brother's computer, his doesn't work in mine, and I highly doubt a brand new 1950x is DOA.  And, yes 750w G2 works cuz I'm using it right now for an OCed i7.  Before someone asks, yes I checked the cables and the pins.  Everything was wired right and there's no bent pins.  So, there's something wrong with the mobo.  The gear light turns on, but nothing else turns on.

×