Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

That_PC_Kid

Member
  • Content Count

    757
  • Joined

  • Last visited

Awards


This user doesn't have any awards

1 Follower

About That_PC_Kid

  • Title
    Member
  • Birthday 2000-12-21

Contact Methods

  • Discord
    Nova#4636
  • Steam
    Nova
  • Twitch.tv
    GamingWithSuperNova
  • Twitter
    @joeybraghieri

Profile Information

  • Gender
    Male
  • Location
    USA
  • Interests
    Tech, Business, & Politics.

System

  • CPU
    Ryzen 5 2400G
  • Motherboard
    ASRock AB350 Pro4
  • RAM
    2x8GB G.SKILL Flare X
  • GPU
    MSI Armor RX 580 8GB
  • Case
    Corsair R100
  • Storage
    128GB ADATA M.2 SSD & 1TB Seagate Barracuda HDD
  • PSU
    Corsair CX550M
  • Display(s)
    21.5" AOC 1080p60 Monitor & 32" Samsung Smart TV
  • Cooling
    Wraith Stealth
  • Keyboard
    Corsair K55
  • Mouse
    Logitech G502
  • Operating System
    Windows 10 Pro

Recent Profile Visitors

1,205 profile views
  1. @TetraSky It worked. I don't know why I didn't think of uninstalling G HUB first. Thanks.
  2. I've been using LGS and I installed G HUB but I don't remember if it forced me to or no. I'm gonna try uninstalling G HUB since LGS forces me to open G HUB.
  3. I want to up my DPI on my G502 but when I open up the Logitech Gaming Software it says that G HUB is supported with my mouse and won't let me do anything but open G HUB. However, G HUB is super basic and doesn't seem to have any features other than labeling my current mouse settings. How can I get G HUB to work?
  4. This issue just started today as I turned my PC on and I can't find a way to fix it. My PC will boot up just fine but then when I get to the login page nothing comes up. It's just a blurry screen. I've tried using F8 to boot into recovery mode but that is not working at all. Does anyone know how to fix this?
  5. He's trying to install Win 10 on it. When he installs Win 10 it will automatically allocate a volume and letter for the drive. For some reason it just won't let him select the drive from the Windows installation menu.
  6. If it shows up in the UEFI then it works. Maybe its not formatted correctly. I'm not completely sure.
  7. That_PC_Kid

    Panel Model

    Just use the warranty and have them ship a new one.
  8. Try reseating the M.2. If that doesn't work then the device might not work.
  9. Unplug all other storage devices but the one you want to install Windows on.
  10. Sorry that I'm late to replying but I'm not sure what the "2N" means.
  11. Yeah, that is. You should try running other benchmarks and some stress tests just to make sure everything is okay. Then try to find out what is wrong based on the results.
  12. There's a Google Chrome web extension that works well if you both have great internet connection. It's made by Google. https://chrome.google.com/webstore/detail/chrome-remote-desktop/gbchcmhmhahfdphkhkmpfmihenigjmpp?hl=en
  13. Add a 1TB WD Blue HDD and you'll be set. I do recommend going for the R5 2600 over the 1600. You're build is fine how it is for what you want to do with it.
  14. It's your RAM. Try switching out modules for different ones.
×