The_Armbiter

Member
  • Content count

    17
  • Joined

  • Last visited

Reputation

  • check
    Agree 0
  • info_outline
    Informative 1
  • tag_faces
    Funny 0
  • thumb_up
    Thumbs Up 0
  • thumb_up
    Likes (Old) 0

Awards


This user doesn't have any awards

About The_Armbiter

  • Title
    Newbie
  • Birthday 1999-08-13

System

  • CPU
    i5 6600k
  • Motherboard
    ASRock Z170A-X1/3.1
  • RAM
    16 Gigs
  • GPU
    Zotac AMP! Extreme 1070
  • Case
    NZXT Phantom
  • Storage
    Multiple different Drives
  • PSU
    Corsair CS750M
  • Display(s)
    One I-INC display + One standard Dell Display
  • Cooling
    Air, Hyper 212 Evo
  • Keyboard
    Standard Dell
  • Mouse
    G502 Proteus Specturm
  • Sound
    SADES A60
  • Operating System
    Win 7 Master Race

Profile Information

  • Gender
    Male
  • Location
    Mars, The Milky Way
  • Interests
    Video Games
  • Occupation
    McDonalds

Contact Methods

  • Steam
    The Armbiter
  • Xbox Live
    Drakenstein98
  1. The Zotac one, it looks nice. And I love Zotac's cards
  2. It was in storage, the teachers know that the school scraps everything for free, so one of them put it in the storage, the IT guy let me have them
  3. The top
  4. I just got a i7 2600k and motherboard free from my school. I was wondering if the CPU socket (where you put the CPU) is supposed to be missing pins? I pretty sure it isn't so I think board is dead
  5. I have a 502 and I love it, it is the best mouse I have ever owned, and yes it's fine on a wood desk
  6. Already had MSI afterburner, but thanks, and no, my card maxes out at about 60 C ish, I have a very aggressive fan curve, and the card's cooler is massive
  7. 750 watt Corsair CS750M No problems with power
  8. I'll try it thanks, I've already reseated my GPU, but I'll check connections
  9. I'll be playing games and about maybe 30 minutes in the game just crashes, it's never done this before. When it does happen it usually says something about a graphics driver crash, I have tried reinstalling the drivers 5+ times and still no change. Zotac AMP! Extreme 1070, no OC other then factory OC
  10. I set my fan speed at 100% through the BIOS
  11. My Processor, the heatsink fans. I probably could've elaborated more
  12. Should I keep the CPU fan at 100% at all times, or create a fan curve for the fan?
  13. Hyper 212 Evo
  14. Okay
  15. Aida64 for about 10 minutes, no failures About 30 C idle 50 C under load