Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

W-L

Moderator
  • Content Count

    26,849
  • Joined

  • Last visited

Awards


About W-L

  • Title
    Technology = Lifeblood

Profile Information

  • Gender
    Not Telling

System

  • CPU
    Intel 4790K @ 4.8GHz
  • Motherboard
    Asus Z97-Pro
  • RAM
    16GB Kingston Fury 1866MHz
  • GPU
    Gigabyte G1 GTX 970 OC'ed
  • Case
    Modified Corsair Obsidian 650D
  • Storage
    120GB Samsung 840 Pro & 3TB Seagate Barracuda
  • PSU
    Corsair AX760
  • Display(s)
    Dual Dell P2311H
  • Cooling
    Custom Watercooling Loop
  • Keyboard
    Corsair K70
  • Mouse
    Corsair M60

Recent Profile Visitors

19,060 profile views
  1. Might be some residual dawn soap or something reacting with the fluid if it's coolant in the loop.
  2. If I recall you cleaned your loop recently, was it properly rinsed out before refilling? That looks very much like detergent or soap bubbles and not just from turbulence from filling.
  3. A little bit of water noise is normal when you first start up as the air makes it way up to the highest point as there is always going to be a small pocket of air no matter how well they will it.
  4. If the case didn't come with any your best bet would be to make your own using some foam sheets and to cut slits into it for the pass through.
  5. If you have soda give it a try but it being a fairly light weight particle it may not have enough mass behind it to really etch the plastic. For corundum (FeSi) referring to the red type it will most likely stain the plastic if the fine dust gets trapped in it same for dark/brown colored aluminum oxides. For aluminum oxide I was referring to the white aluminum oxide grit. As for grit size it really depends but since I don't have a lot of experience with using different sized medias I can't really say what would be best. I would assume something a little finer than than what you would normally use should give good results.
  6. For plastic it needs to be a very sharp abrasive like aluminum oxide but the main issue is if it builds too much heat and it ruins the surface or starts embedding particles into the plastic itself so it needs to be very controlled.
  7. Anker makes some pretty good battery banks that are trusted. https://www.amazon.com/Anker-PowerCore-Ultra-Compact-High-Speed-Technology/dp/B0194WDVHI
  8. Yes there are ones that can support more than one NVME drive and even do software RAID multiple together. https://www.amazon.com/ASUS-M-2-X16-V2-Threadripper/dp/B07NQBQB6Z -Moved to Storage Devices-
  9. If it ran a pastel fluid it would be a good idea to tear it down for a proper cleaning especially if there was any issues with settling of particles, color change etc. You can do a flush and fill t get rid of the majority of particles and refill if you are going back to the same pastel fluid but I would only do so if there were zero issues with the fluid previously and it is just within a regular time interval for a fluid change.
  10. Your best option is to take it apart and properly clean it if there is build up in the blocks and fins. It's not recommended to run the loop is a mixture of vinegar, only use that on the rads for cleaning and to flush them out thoroughly afterwards.
  11. I'm sure Corsair can get you a replacement if you contact them, only other time I've seen an issue with mounts breaking is the actual plastic bar that is on the board where the little nub that the bracket seats into gets worn out or cracks.
  12. Depends on how warm it is, but in general plugging into the one upstream will resolve it since you do not have an extra splice/connection in your cable length. Every splice and connector in a chain can add some extra resistance and the potential for heat build up.
  13. The thread was previously moved into the GD section as it didn't meet the guidelines, once updated it may be eligible to be reinstated.
  14. You are still pulling current through the first connector that is not connected since you are using the second one in the chain, while it shouldn't really be too warm it is an extra terminal in a chain which in theory can add resistance and potential for heat. You can just connect the GPU to the one upstream instead so it's not going through that extra connector. However if it's warm to the touch I would worry about a bad wire connection causing extra resistance.
  15. Can't say I've seen that before, only thing I can think of is the mount was tightened too much and it broke at the weakest point where a stress rise can occur. There are two hard bends in that area, one 90 degree and another stamped portion right along the length so it could have work hardened the material making it brittle.
×