Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Jetsada

Member
  • Content Count

    36
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Jetsada

  • Title
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. The LED on my kraken x62 is stuck in a certain color like for example; red, cyan sometimes it goes to white but most of the time its not working. All I see its just black and no color or rgb I want. It's suppose to work without CAM software. After I installed CAM software and drivers, nofthing changed... I'm concerned that my kraken x62 is broken-ish, the pump, fans and water is flowing nofthing wrong with that. its just the LED that bothers me... Help would be appreciated alot! Thank you in advance.
  2. Ok im 100% sure it's my cpu cooler kraken x62. I have done everything possible I could...I still have warranty...i really think its just the LED not showing up yesterday they were kinda dying because the LED light did not spin just stuck there... water is pumping and everything else of the kraken is working
  3. I installed the CAM software, update the firmware of cam software. Checking in the box for the RGB to show lights. nofthing is working. I am currently going to update my BIOS version and what drivers.
  4. Specs: Asus rog maximus XI Hero Asus RTX 2070 2x8GB RAM of G.skill trident Z CPU i7 9700k I have this problem with my kraken x62 since yesterday. I haven't used my computer from June the 23rd to July the 21th. However I am using the Aura software for my lightings and never had problem with my kraken or whatsoever. its suppose to work without using CAM software from Nzxt. I tried to unplug all the cables, checking for problems and plugging back in again. Found no problems. (see attachments) Another minor thing, my motherboard is staying on static red light. (see attachments) All other RGB components work fine as intended. Anyone know what I need to do? I could send the cooler back for a new one if thats easier to fix it. Thank you in advance.
  5. @jstudrawa I replaced my RTX 2070 Asus, with my 3 year old GTX 960 from Gigabyte. I am so happy, that I know the GTX 960 is working well (ofc lower fps but it doesn't freeze the game or crashes) I am now 1000% sure my RTX 2070 is faulty one and should be send for RMA A.S.A.P i guess. Glad I had a spare part to test.
  6. I will surely do! Oh another thing, when I fill in the Serial Number of the gpu product on the Asus global website it works fine, but that's not where I belong on the US/Canadian version. I found eu/nl version of it, the Serial Number doesn't work it says: Incorrect SN..I filled it excatly 3 times or so...hmm really frustrating. I think calling the Dutch Asus is the way to go for me.
  7. Thank you so much for everything! I will do it tomorrow or saturday, since thats when I have time to call.
  8. Mabye dumb question but, my product manufacturer is:ASUStek COMPUTER INC (made in china) but I should be calling ASUS in my country or the the global one?
  9. I live in the Netherlands/Europe, the link you gave me I can use it? I though its for customers who bought it in Canada/America and the manufacturers itself aswell. I guess its okay for me
  10. Things you mention are good options, and let me respond to that accordingly, - No I haven't reinstalled the GPU drivers (how do I delete the gpu drivers? And then just install them from nvidia geforce experience?) - There is no new patch coming out at the moment for Total warhammer 1 and 2 and COD4 (issues on 3 of those games) I have not tried game like, heroes of the storm, dota yet. But the point is..it should be fine on all games, why those 3? - I have installed the newest windows update and drivers for my GPU. - Reseated the GPU a couple of times and reseated the RAM sticks, and also changing to different slots, nofthing helped. And put the RAM back into the recommended config. - I think I have reinstalled windows (when I set back to factory reset as last resort, and did not helped) - The screen doesn't looks like what's in the picture when I play Call of Duty 4, it just completely freeze everytime I start up after 1 min it happends. It also freezes and have bugged out graphics like in the picture on Total warhammer 1 and Total warhammer 2 (thats 2 games) and they both freezes. - My psu is an: Corsair RMx white series RM750x (750W) 80 plus gold 100-240V I honestly, getting really tired and don't know what else to, because I'm pretty sure it's an hardware problem, and the GPU is the faulty one... since I have isolated the problems and check most of the options I had..
  11. Okay thank you! But I'm no pc professional, do you think I have to RMA my gpu? I bought it on December the 26th 2018. And I have this graphical issue starting from yesterday...
  12. This is one of the example I have when I run this game: (when I close the game and start up it always go like this, and the game freezes only task manager responds, but not always fast enough) I feel like I have to RMA my GPU...how do I do this? I bought all pc parts togheter in one go, from a Dutch website, Azerty.nl Any help would be amazing. And the game is to look like this: Example B: A: B: I can't just play one of my favorite games anymore... My spec is: i7 9700k 3.6 GHz 8 cores, 8 threads NZXT kraken x62 cpu cooler G.Skill Trident Z RGB DDR4 16GB (2x8gb) dual channel mode M.2 SSD samsung 970 evo (m.2 2280) WD black HDD 2TB (WD2003FZEX) Asus ROG STRIX RTX 2070-O8G-Gaming GDDR6 Nzxt H500 Corsair RMx white series RM750x power supply Asus ROG Maximus XI Hero (z390)
  13. the new bios version file looks like this, drag the file into an empty usb stick? I should put it somehow on a USB stick? and then restart and go into bios?
  14. I have a download the new file (my current old bios is version 0502) the new one is 0702, But it's a winrar file when I open it, I get this:
  15. I have been stressing about my BSOD over couple of days....so it does really fix all of my problems and probally for gaming too I guess..since Its crashing/freezing..I would look up how to properly update my bios, do u have any suggestions?
×