Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Johnzilla97

Member
  • Content Count

    13
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Johnzilla97

  • Title
    Newbie
  • Birthday 1997-07-23

Contact Methods

  • Discord
    Johnzilla97#6969
  • Steam
    Johnzilla97
  • Origin
    Johnzilla97
  • UPlay
    Johnzilla97
  • Reddit
    Johnzilla97

Profile Information

  • Gender
    Male
  • Location
    Tomar, Santarém, Portugal
  • Occupation
    Software Programmer at IBM Portugal

System

  • CPU
    Intel Core i7 5820K 3.30GHz 15MB
  • Motherboard
    MSI X99S MPOWER
  • RAM
    Kingston HyperX Fury 16GB DDR4 2400MHz (4x4GB)
  • GPU
    ZOTAC GeForce GTX 1070 AMP Extreme CORE
  • Case
    Corsair Carbide 500R White
  • Storage
    Samsung 970 EVO PLUS 512GB / 2x 2TB HDD
  • PSU
    Corsair RM850i (80+ Gold)
  • Display(s)
    Dell UltraSharp 24" U2414H
  • Cooling
    Corsair H100i RGB Platinum SE
  • Keyboard
    Corsair K70 RGB MK.2 (Cherry MX Red)
  • Mouse
    Corsair Glaive RGB
  • Sound
    Behringer U-Phoria UMC22
  • Operating System
    Windows 10 Pro 64Bits

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. You should do a fresh install of windows. Linus made a video series some months ago ($1500 Gaming PC Secret Shopper) and he reviewed the same machine you have, they found some performance issues regarding the software installed on the machine and a clean install solved the problems. I will leave the final episode here:
  2. Overclocking will not help, because your motherboard does not support it (A320 chipset). Correct me if I'm wrong. Your CPU might bottleneck your GPU, so I would recommend upgrading it to at least a Ryzen 5 if you can.
  3. Your specs are balanced, so there's no clear reason to bottleneck. Can you do some stress tests with AIDA64 and some benchmarks with 3DMark (or other)? Maybe the results show us some clues to the problem.
  4. Good to know you got it solved! Some Corsair devices are a bit picky with the accessories you plug to them, that just proves it once more.
  5. love the profile pic man

  6. You can try the following things: Reinstall the driver - Go to Device Manager > locate the device > Uninstall device > Then Scan for hardware changes. It should reinstall it. Plug it in other spare computer if you can and install iCUE in it - It may seen stupid but I once had a firmware problem with my keyboard and mouse (also from Corsair) and force update was always failing, I plug them in other computer I had, and the firmware install went fine. If none of this works RMA it, probably you have a defective unit.
  7. Does it behave the same way when iCUE is NOT running? Because there are hardware profiles and software profiles with Corsair devices and it might do a difference.
  8. Connecting to other SATA power connector won't solve the problem I suppose... Is iCUE reporting a firmware update failure or some sort of warning on the device? Try a force update of the firmware, maybe it solves.
  9. Have you tried connecting the graphics card to other PCIe slot? Maybe the slot is bad... If it doesn't solve try with another graphics card if you have a spare or try that GPU on another computer.
  10. Are you using some sort of adapter for power (Eg: Molex to SATA)? I had a similar issue with my Corsair H100i RGB Platinum SE, disconnected the adapter and it solved the problem.
  11. Did you check the S.M.A.R.T. of the storage drives? Since you have some files getting corrupted, it could mean that the SSD/HDD is failing. You can check that by downloading Crystal Disk Info, or HD Tune Pro.
  12. Also, check if the temps of both CPU and GPU are ok while gaming. If that's not the problem, then check for any logs on Event Viewer and for BSODs.
  13. You can cap the FPS of (almost?) any game with Rivatuner from MSI Afterburner.
  14. My rig is not even capable It's time to get a GTX 980 Ti... but my wallet is not ready. Rig name: No nameCPU: Intel Core i7 5820k (No OC)GPU: Nvidia Geforce GTX 750Ti (OC +200MHz) (I had no extra money to buy a decent GPU)RAM: 8GB 2133mhz DDR4Score: 0
×