Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

deadmoo5e

Member
  • Content Count

    88
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About deadmoo5e

  • Title
    Member

Profile Information

  • Gender
    Not Telling

System

  • CPU
    intel i7 4770k
  • Motherboard
    Maximus VI Formula
  • RAM
    Corsair Dominator Platinum DDR3 16GB 1866 MHz
  • GPU
    EVGA Geforce GTX 1080 Classified
  • Case
    Fractal Design Define R5
  • Storage
    OCZ Vertex 4 256 GB, Seagate Barracuda 3TB
  • PSU
    Corsair AX 750W
  • Display(s)
    BenQ XL2420Z, BenQ XL2420T
  • Cooling
    Corsair H100i
  • Keyboard
    Logitech G710+
  • Mouse
    Logitech G400
  • Sound
    Bose QC25
  • Operating System
    Windows 10 Home

Recent Profile Visitors

761 profile views
  1. I will consult the holy manual. Thanks for answering.
  2. I was just wondering if a 970 EVO NVMe M.2 SSD 1TB would be compatible with my Acer Aspire V17 Nitro Black Edition laptop. I tried googling the issue but I'm not entirely certain if I can.
  3. Yeah will do. I thought about reinstalling windows but I'm so sick of doing that. Everything seems to be working just fine.
  4. It does show up in this menu as an SSD. Not a HDD. So it's weird that I'm having this problem.
  5. I recently changed a Western Digital HDD with a Kingston A400 SSD. I used the same SATA cable connected to the same connector on the motherboard. Under 'my computer' it shows up with the correct storage and everything. Seems to be working just fine. Installed and ran a few games from the kingston drive. But in task manager it's listed as my old Western Digital drive. Is this problem something I can ignore or is it gonna cause issues down the line? Any way to fix it?
  6. I'll see what I can find. I don't have much access to extra electronics. Guess I'll have to bump this thread later.
  7. I might have a GTX 550 Ti lying around. I could try that if I can find it.
  8. Sorry I only have access to this PSU ?
  9. I moved back into a new place a few months ago. I've had this computer since 2014. Moved it a few times but only a few meters. Additional info is that when I played Tekken 7 it straight up crashed. Got a black screen out of nowhere.
  10. Added the specs. The fans are running as normally as far as I can tell. The beeping sounds I get when I press power on are the normal sounds I used to hear before when my system worked.
  11. Give me two minutes and I will get back to you on that. And I'll add the specs
×