Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

CasualNick

Member
  • Content Count

    26
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About CasualNick

  • Title
    Member
  • Birthday 1994-12-17

Profile Information

  • Gender
    Male

System

  • CPU
    AMD FX 6300
  • Motherboard
    Jank 100$ MSI Mobo
  • RAM
    8 GB DDR3
  • GPU
    Nvidia 750 Ti
  • PSU
    500W
  • Keyboard
    Steelseries Apex Raw
  • Mouse
    Logitech G402
  • Operating System
    Windows 8 64-bit

Recent Profile Visitors

531 profile views
  1. Well, i assumed it'd be obvious what was causing it to hit above 50% honestly. but nothing was over 150+ mb. But I will keep on the look out if it raises or drops. Until then, I appreciate the help <3
  2. I looked through it for a bit, but nothing stood out. The service host seemed to be the one thing taking up quite a bit. I reset my pc, and opened task manager after startup to see if i could catch anything draining it. But i'm at about 16% now. Gonna try and open WoW and see if it flickers back up.
  3. I'm running a scan on malwarebytes now. But as far as recently installed programs n such, nothing un-ordinary. I haven't installed anything in months it feels like. Only thing that's consistently open in the background would be Discord and maybe battlenet. I'm a tad stumped
  4. So, never had any issues until just the other night, when WoW started dropping to about 20 frames. Now my PC is at a standstill on literally anything I try to do. I can barely do anything on Chrome, let alone anything at all. Any idea what could be causing this, or any fixes? Much appreciated.
  5. Hello again everyone. So lately, Cox internet has been trying to hassle me again into giving them more money it feels like. But who knows. I have 120Mbps Upload. But i'm consistently dropping to about .35 and then back up to 60~ or so. It's so frustrating, and becoming impossible to play any games, or even watch youtube videos. I cant even open a vine. Yes, i have restarted my modem. I've also reset my IP. But the two only seem to make a difference for about 10 minutes. Any Ideas?
  6. EXCUSE ME SOCKS AND SANDLES ARE THE PINNACLE OF FASHION.
  7. So in the "Cooling Challenges! - Personal Rig Update 2015 Part 6." Linus is wearing these god awful shoes. This isn't the Linus I subbed to years ago. Personally I am offended. I will be writing an angry letter to the shop asap. How could you.
  8. I actually am using OBS, is there possibly some settings I have that would be tampering with it?
  9. This 144hz asus monitor is stellar so far for myself if you're willing to grab a few more bucks if I'm doing the currency rates right. Always has sales on It as well. http://m.newegg.com/Product/index?itemnumber=N82E16824236313&nm_mc=KNC-GoogleAdwords-Mobile&cm_mmc=KNC-GoogleAdwords-Mobile-_-pla-_-Monitors+-+LCD+Flat+Panel-_-N82E16824236313&gclid=CjwKEAjw3fG4BRDsn9GAv7T2zEkSJACNJdjgcHXQHnJNb5miy-KSZnfD51LCbFg9vXCpWNEPdPrhOhoCkT_w_wcB&gclsrc=aw.ds
  10. Hey all, so I'm looking more into streaming and it's become a problem with a majority of games, I expect fps to tank a bit, but cpu usage is getting to be an issue from what I understand. Is there a budgetable way to upgrade a part or two to lighten the load while streaming? current specs: i5-4690k Nvidia gtx 960 SSC (2gb) Z97 gaming 5 mobo 8gb ram while I understand ram may be an issue, is there any particular thing I can fix immediately?
  11. Everyone is amazing, thanks for all the informative and quick responses!
  12. Im not certain the exact model. But it's a thermal take 600w. I don't exactly have the money for another 100$ out of pocket :L
  13. Hey friends. Just wanted to get the assurance of others before spending a handful of money. Might as well post my whole rig. 600w psu MSI Gaming z97 gaming 5 intel 4690k Windows 8 64bit. Evga gtx 960 2gb ssc
  14. My OS is currently on my SSD and I transferred my Windows OS from the HDD to my SSD with a Samsung Migration tool/kit. Would that cause problems? Hate to ask, but how would i go about opening it while I can't even open Chrome? I can put it on thumb drive, but is there some sort of work around?
  15. Also note, I do not have a recovery disk!
×