Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

X_Rated_Box

Member
  • Content Count

    1,075
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About X_Rated_Box

  • Title
    lonelystoner🚬
  • Birthday January 30

Contact Methods

  • Steam
    -
  • Origin
    -
  • Battle.net
    -
  • PlayStation Network
    -
  • Xbox Live
    -
  • Star Citizen
    -
  • Twitch.tv
    X_Rated_Box
  • Twitter
    -
  • Website URL

Profile Information

  • Gender
    Male
  • Location
    NRW, Germany
  • Interests
    The Female mystery
    All kinds of Tech
    Cubing (Rubik's Cube for the stupid:P)
    Drumming
    Music (any Genre)
    Sport
  • Biography
    Born ,lived ,till now
  • Occupation
    Student

System

  • CPU
    Intel I5 4690k @4ghz
  • Motherboard
    Msi Z97 SLI Krait Edition
  • RAM
    16gb Kingston HyperX Fury Black series 1866mhz
  • GPU
    Gigabyte Geforce GTX 970G1 Gaming OC to 1617mhz
  • Case
    NZXT s340
  • Storage
    WD Green 2tb/SSD HyperX 128gb
  • PSU
    EVGA Supernova 750 G2
  • Display(s)
    AOC I2369VM 23" x2
  • Cooling
    NZXT Kraken x61
  • Keyboard
    Logitech g710+ (soon to be modded)
  • Mouse
    Razer Deathadder Chroma
  • Sound
    Harman Kardon SoundsticksIII
  • Operating System
    Win 10

Recent Profile Visitors

3,223 profile views
  1. Ok I will be on the Discord later today when will you be online or when can i talk to somebody? @AAJoe
  2. Hey guys its been a while since I've posted last time, but I just got my pair of Audiotechnica M50x's and my new ModMic 5. My problem is that only the unidirectional mode works and not the omni one. Lets say the Unidirectional one is pretty quiet and the other mode (omnidirectional) outputs only very messy whitenoise. Any suggestions on what I could do ? I've tried muting an unmuting it. I've tried different 3.5mm jacks. I've tried most of the settings in Windows sound manager. Will a USB soundcard really fix my problem or is it definetly broken, DOA? I'll try to add some audiofiles later Omnidirec.mp3 Unidirec.mp3
  3. Sorry for SR but I already found out that one of my DP cables is broken but TY anyway <3
  4. Okay Im back Apparently one of my monitors turns on during boot but right before the lock screen it turns off ...
  5. And I'll also try the "unplug wait an hour and replug method" C u in an hour
  6. Yeah, today I got this problem after I cleaned my PC (Taking the GPU out, canned Air etc. u know the procedure), but now after reassembly and turning it on the Display Ports "wont work" I tried plugging in the monitors in all of the 3 DP's of my GTX 970 (G1 Gaming). When I plug them out and plug them in again they turn on from standby mode to on, then the DP NO SIGNAL comes and they turn of again. And thats how my setup looks usually ...atm im using another monitor over DVI. I also cant test the Display Ports on my 970 because the two AOC monitors are the only DP monitors we/I have Already thank you in advance
  7. Hope the best for you like i said what cooler did u get? :3
  8. Yeah do that best luck for you fellow racer
  9. Then try the support again or maybe the online service of the shop u bought it from
  10. seems to be some kind of a static problem... RMA it as fast as possible humming can come from some of the coils... Just ask for a replacement or at least contact support about it!!!
  11. Like I said the only gaming would be VEEEERY light gaming with stuff like the sims ... not crysis 3 or anything... .-. It should be more of a multi purpose university laptop
  12. Hey guys im looking for a very good price/performance ratio notebook requirements are 15" display, not too heavy and big, a dvd drive and it should be able to play Life is strange and Sims 3 fluidly (dont aks its for a friend of mine) It also should run Audio programs for voice recording and stuff like Abelton fairly smooth thx for relplies in advance
  13. Got the UE Megaboom today it was a super steal a few days ago for 177€ !!!

     

    And it sounds AMAZING for the size and the price it was worth every penny!

  14. Thank you a lot they answered me and told me it was no problem ...but I'll have to wait to see if it works with the new Soundcard :D
×