Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SwitchDC

Member
  • Content Count

    8
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About SwitchDC

  • Title
    Newbie
  • Birthday 1995-09-11

Profile Information

  • Gender
    Male
  • Location
    Slovenia

System

  • CPU
    i5 4690K@4.4GHz
  • Motherboard
    Asus Z97-PRO GAMER
  • RAM
    16GB HyperX Fury 1866MHz
  • GPU
    Gigabyte GTX 970 G1 GAMING
  • Case
    Phanteks Enthoo Luxe
  • Storage
    Samsung 850 EVO 256GB & Seagate 1TB Barracuda
  • PSU
    XFX XTR 650W
  • Display(s)
    ASUS VX279 & LG E2250
  • Cooling
    Cryorig R1 Ultimate
  • Keyboard
    Logitech G213
  • Mouse
    Logitech G703
  • Sound
    Logitech X-530 5.1
  • Operating System
    Windows 10
  1. The TIM was spread somewhat good. It's probably not spreading as much due to the warp in the socket area. Spacers wouldn't work in this case because the standoffs on the socket side are completely flush with the mobo. It worked on the previous cooler because the standoffs were different. In any case thanks for the answers. I'll be upgrading the system soon anyway so this mobo will go out the window
  2. So I've just bought a Liquid Freezer II 240 and I installed it per instructions in the manual. As soon as I did a stress test to see the temps on my 4790K I was shocked when I saw them reach 100°C. I rechecked everything to see if I forgot to tighten or install anything but everything was fine. Fans were spinning normally and the pump was at 100%. My settings and hardware at the time of the test: 4790K 4.4GHz@1.2V Asus Z97 - Pro Gamer mobo 2x8GB HyperX DDR3 1866Mhz Arctic Liquid Freezer II 240 XFX XTR 650W Enthoo Luxe - 2x140mm(front), 1x140mm(rear), AIO(top) I'm wondering if this is an issue with my motherboard or socket or cpu. I used to have a Cryorig R1 Ultimate on which the mount got a bit loose so I had to make it work DIY style. When I took the LF240 down to see the mount it seemed like it wasn't making complete contact with the CPU die which got me thinking that I might have warped my mobo with the previous cooler - bent the socket inward. Also at stock my 4790K on the LF240 runs at ~65°C. I was testing with Cinebench r20 If anyone has any insight into this I'd appreciate it a lot.
  3. The Nascita looks beautiful, has the right amount of buttons for me and well, it just looks awesome.
  4. Vessel Username: Cencho Hardline Water Cooled PC Build Log: https://www.vessel.com/videos/JYZEYDYx0 Phanteks Enthoo EVOLV - Classic Unboxing, NCIX Courtyard: https://www.vessel.com/videos/CBR6_NDEI Shares: - Instagram: https://instagram.com/p/0nwLQIK7ZB/ - Facebook: https://www.facebook.com/nothingXD95/posts/671916069598255?pnref=story - Twitter: https://twitter.com/DenisCentrih/status/580443913443500032
  5. Would be an awesome upgrade from my i3 530 I'd finally be able to do some serious gaming and probably start streaming for fun.
  6. Such gorgeous cards and performance better than the Strix variant. The maxwell architecture does wonders.
×