Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

xnoobftw

Member
  • Content Count

    4,336
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About xnoobftw

  • Title
    Veteran
  • Birthday 1997-12-22

Contact Methods

  • Battle.net
    xnoobftw
  • Origin
    xnoobftw
  • Steam
    Tinder
  • Twitter
    https://twitter.com/xrandomperson

Profile Information

  • Gender
    Male
  • Location
    Singapore
  • Occupation
    Student

System

  • CPU
    i7 4770
  • Motherboard
    MSI H87-G43 GAMING
  • RAM
    12GB Kingston Ram
  • GPU
    Tri-X R9 290x
  • Case
    Corsair Spec 03
  • Storage
    Samsung 840 EVO 250GB SSD and 2TB Toshiba Hard Drive
  • PSU
    EVGA G2 850W
  • Display(s)
    Samsung S22D300 / Dell U2414H
  • Cooling
    Tons of corsair fans
  • Keyboard
    G710+
  • Mouse
    G400s
  • Sound
    G430 / Bose Companion 2 Series III
  • Operating System
    Windows 8.1 64-bit

Recent Profile Visitors

2,607 profile views
  1. 2666mhz cl14 is what i would assume to be safe
  2. I would doubt the stability
  3. From my experience only flare X is able to reach 3200mhz cl14 I've tried the exact kit (trident Z RGB 3200mhz 16gb kit) on a ax370 gaming K7 with latest bios and it fails to reboot when XMP is enabled I had to clear cmos to get back into bios
  4. Swapped casing from a Corsair Spec 03 to a Fractal Design Define R5. Thoughts on cable management and overall look? Specs I7 4770 + MSI H87-G43 Gaming 16GB Kingston 1600mhz CL9 (4*4GB) Samsung 840 Evo 250GB 2.5" SSD Toshiba 3.5" 2TB HDD 7200RPM Coolermaster Hyper 212x CPU Cooler Sapphire R9 290x Tri-X 4GB EVGA G2 850w PSU Fractal Design Define R5
  5. xnoobftw

    Airflow question

    Nope
  6. xnoobftw

    Airflow question

    Not dusty at all! As shown in the pic
  7. xnoobftw

    Airflow question

    R9 290x tri-x
  8. xnoobftw

    Airflow question

    Photo of PC enclosed in spoiler bracket ^ Specs in signature (Recently moved parts to new casing Define R5) Front: 2 X SP120 High Performance on mid (R5's Fan controller) Rear: 1 X SP120 quiet edition on 90% all the time Overwatch GPU (R9 290x Tri-X) Temperature during steady state With side panel on: 85c Without side panel: 77c Any way to lower my GPU temp? D: Is it an airflow issue?
  9. It's actually for someone else not my rig but i did build it!
  10. Here are some photos of this sick rig i built Specs: I7 7700K With NZXT Kraken X52 MSI Z270 Gaming Pro Carbon Trident Z 3200mhz 32GB (16GBx2) 960 Evo 500GB M.2 SSD Mastercase Pro 5 Geforce GTX edition MSI 1080ti Seahawk EVGA G3 850w
  11. xnoobftw

    Internet disconnects every few minutes

    Not yet... gonna try that
  12. Hi guys i need some help Im on a cat5e connection to my 10mbps router and i seem to get disconnects every few minutes or so. Only by reseating the ethernet cable on my router does it solve the situation. There are lights blinking on both ethernet ports (on PC and router) and my PC shows that there's connection like so too. Any solutions to this? Note: -I've installed the latest network drivers -Other PCs/WIFI works normally so it isnt a router issue -My PC specs are in my signature
  13. xnoobftw

    USB 3.0 front IO panel partially working

    Windows 10 64bit! Should i try installing the windows 7 version then? does it work that way?
  14. xnoobftw

    USB 3.0 front IO panel partially working

    the only one i can test with is my external hard drive It is running at 3.0 speeds with only one of the port. The other it can only run at 2.0 speeds (evident from the led light that lights up blue from my hard drive if it is running at 3.0 speeds and white if it is running at 2.0 speeds) how do i reinstall my 3.0 usb driver? Im using a MSI h8g43 gaming mobo with a 4770
  15. Hello guys so my current situation is that one of the two front usb 3.0 ports works at 3.0 speeds with my external hard drive while the other only works at 2.0 speeds Any solution? D:
×