Jump to content
  • entries
    8
  • comments
    10
  • views
    4,354

pacman is dumb really dumb from time to time

Herr.Hoefkens

343 views

 Share

here is another thing that really sucks hairy monkeyballs in any arch based distro:
so apparently pacman knows these two packages are actually the same as they occupy the same slot (conflict):

:: ki18n and ki18n-git are in conflict. Remove ki18n-git? [y/N] (=>both answers haave the same effect the process exits)



 but even if sees the conflict it doent actually know these are the same packages,
since the -git version is installed lets check what version of the package is currently on the system (and lets see if pacman can see the version):
the version that the -git PKGBUID installed and thus the one currently on the system is : `'5.96.0_r557.g7303138-1'`

lets check what the package i tried to install originaally (that had ki18n as a depency) specified for minimal version of that package:
 

```PKGBUILD SPECIFIES : 'ki18n>=5.82'```


so my install fails for a package that is already on the system its version is perfectly fine , pacman  is aware about all of it but it cant seem to figure that out wen trying to resolve depencies as it then reports `ki18n` is not installed ... lets get that , it finds a pkgbuild of` ki18n` with version `'5.95.0-1'` , checks for previous versions and conflicts , finds that there is a conflict. a newer version as the one its trying to install actually , it then prompts what it should do keep the installed one or install the older-new one. choosing to keep the installed version exits because even if the thing is on the system it suddenly forgot abouut the conflict it just found didnt check versions , and dropt back to shell, choosing to install the older version , ofcourse also fails because unless i manually installed `ki18n-git` , its prolly pulled in as a depency so there are prolly depencies that require` 5.96` or newer.

 

 

not saying gentoo's system is flawless for git packages but atleast it works ,.. (git packages are masked and get version 9999, but they actually do have the same lot as the non-git release versions on the system, ofc packages with version 9999 never have a newer version so , to fix that they add these to a set : @live-rebuild, wich can be run manually or if set up @Smart-live-rebuild, wich wil check each git repo for updates and updates the ones that have updates along with a regular @world system update.

 Share

0 Comments

There are no comments to display.

×